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Abstract 
 
This tutorial focuses on the needs of students of any age who want to plan their studies and develop 
experience on how much time to allocate for planned studies by measurements on actual studying 
time.  
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Preface 
 

To Students who want tools for improving their studying capacity 

 

DocumentDictionary is founded on more than 35 years of practical rational student experience in using tools for 
the planning of studies and research, and for organized quick access and recall of once studied course mateiral and 
research articles. 
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Chapter 1 The Purpose of DocumentDictionary 

The purpose of DocumentDictionary is to provide a practically useful tool for study planning, 
research and recall of previously studied courses, manuals and research articles. 
DocumentDictionary builds on knowledge already present in the Public Domain more than 20 years ago. 

By using DocumentDictionary, you will learn more about your own studying capacity and performance, while 
having a tool to plan and track your studying progress. 

You get an archive to store and organize your references to teaching material and research articles on you personal 
workstation or laptop. In addition the tables of contents in the teaching material can easily be imported and used to 
plan studying time, track studying progress and store own comments and summaries for recollection of the studies 
later. 

It is fun to study when you can see your own progress, and at the same time get an organized index to the teaching 
material and research articles you already have worked your way through. 

You will be surprised how useful it is when you need to quickly rehearse a previously studied course when you 
start a new course that builds on that theory. This may occur in the curriculum, or in a work assignment half a year 
later, or sometimes years after you studied a course or other documents. 

 

For teachers in academy and industry DocumentDictionary can serve as a tool for planning of interactive and self 
studying courses. The teaching material references with their table-of-contents for the course material can be 
distributed in an easy to use binary format to students, that can also be exported and imported as standard comma 
separated text files in other software tools. 

Collaborative team based course development can be done using a shared relational database, where the whole 
curriculum of courses given by a company or teaching facility can be archived, reused, and serve as repository and 
trace of version and release managed course development over long periods of time. 
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Chapter 2 A Quick Tour through DocumentDictionary 

 
This is a walk through of the the most valuable student functionality in DocumentDictionary. 

 
2.1 Opening an Existing DocumentDictionary and Create a new Reading Schedule............................. 4 
2.2 Planning the Study of a Document.................................................................................................... 5 

2.2.1 Open an existing DocumentDictionary File................................................................................................ 5 
2.2.2 Creating a Category .................................................................................................................................... 6 
2.2.3 Creating a DocumentRecord within a Category ......................................................................................... 9 
2.2.4 Pasting a Reference on a DocumentRecord .............................................................................................. 11 
2.2.5 Pasting a TableOfContents on a DocumentRecord................................................................................... 14 
2.2.6 Updating the PageCount information in a "TableOfContents" ................................................................. 15 
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2.3 Calibrating Your Reading Speed..................................................................................................... 19 
2.4 Recording ReadTime for a Document or ContentContainer........................................................... 20 
2.5 Update or Create AuthorRecords and AuthorDocuments ............................................................... 22 
2.6 Find a string in a DocumentDictionary ........................................................................................... 22 

 
Some text is written in grey. You can skip those if you just want to acquire the knowledge needed to 
use this tool as a productivity enhancing aid which is all right. The purpose of the grey text is "just 
in time" knowledge asset building for getting the most out of computers which are much faster 
servants than humans if computers are told what to do in a language they understand. 

2.1 Opening an Existing DocumentDictionary and Create a new Reading 
Schedule 

Start DocumentDictionary by double-clicking DocumentDictionary.bat typically installed in 
C:\Programs\DocumentDictionarMNP, where M is a number representing the major version of the program, N 
represents a minor verson number and P represents a patch number.  

A Welcome dialog box appears where you can enter your login name that must be 8 characters or less. Since you 
may create a huge number of objects who all will be stamped with your login name, it saves computer storage 
space in simple but fully functional open source database implementations to have a short name  A common 
convention for selecting a login name is using the first 3 letters in your first name, and the  first 2 letters in your 
last name, and adding the last two digits of the year of your birth. 

Use the login identifier Student when going through this tutorial the first time, to make the demo examples work.. 
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The main window consists of a File Edit menu, and two adjacent panes. One that organizes DocumentRecords 
into Categories, and one that organizes AuthorRecords into the same Categories. 

You can open a file with File->Open, and then navigate the Category structure down to DocumentRecords. These 
in turn contain a TableOfContents structure with ContentRecords. 

Open a File, for example: 

 <installation directory>\samples\dd\Foundational_EngineeringDatabase_Theory_Products_R1.0.0.ddi.  

You can navigate in the DocumentCategoryTree the same way as in windows explorer. Have a look at the 
example. Spend at most 5 minutes in this. You can return later when you have completed this manual. 

 

 

2.2 Planning the Study of a Document  
This example requires you having access to a Document that contains a TableOfContents. In the installation 
directory of DocumentDictionary, you find one example under: 

 DATA\Foundational_Engineering_Database_Theory_Products\4_Products\[ROJTEC 2018d].txt.  

The Sample document is named OOCASE_User_Manual_181211.pdf and stored in the directory [ROJTEC 
2018d]. You can use a reference directory like this to store other study material that might be useful with regards 
to a particular document. 

2.2.1 Open an existing DocumentDictionary File 

In this tutorial case we use the file: 
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 <installdir>/samples/dd/Foundational_EngineeringDatabase_Theory_Products_R1.0.0.ddi. 

After you have opened this file, use File->Save As, and give it a new file name, for example: 

 <installdir>/samples/dd/test/Tutorial1.ddi. 

2.2.2 Creating a Category 

When planning a study of documents, you create a Category for that study. Right-click on the 
DocumentDictionary root object in the tree named 
"Foundational_Engineering_Database_Theory_Products_R1.0.0" and select "Create" from the menu. 

 

 

 
A DialogBox appears. You select "Categories" and press OK. 
When you select Create on an object the pop-up Dialog box allows you to select what kind of 
subordinate relationship (Aspect) with respect to the object you right-clicked on, that you want to 
Create a new object in. In this case, Categories that holds Category objects or DocumentRecords 
that hold DocumentRecord objects.  
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A new Category object is created and Form (Object Editor) will appear that allows you to enter a 
name for the Category of your studies, and perhaps a description, if you need to share this with 
colleagues who may need some more details to understand what the Category means. 
 

 
 
Enter "OOCASE" in the Name field, and perhaps enter "Studyplan for OOCASE" in the Definition 
textbox. 
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Then press the button "Store" at the bottom of the form, (and your data will be recorded in the 
primary memory of the computer that runs your DocumentDictionary program, but it is still not 
stored on permanently on the file on the hard disk which is called secondary storage. The difference 
between primary memory and secondary storage is that automated processing in the primary 
memory work on a small fraction of microsecond basis whereas reading and writing to secondary 
storage may take millisecons or even seconds if large data volumes need to be processed. ) 
 
Now you click on the newly appeared "OOCASE" Category Object folder Icon in the 
DocumentCategoryTree in the main window. You may have to click on Window->Refresh Window 
to make the renamed category folder icon update the newly renamed Category and sort itself 
alphabetically into the tree on its current level. 
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The display will be updated. (The DocumentDictionary program will scan the latest data stored in 
the primary memory that stores the data for the Category, and refresh the display in the window of 
your computer where it will render a readable representation of the latest data you entered on the 
screen.) 

2.2.3 Creating a DocumentRecord within a Category 

Now you right-click on the "OOCASE" Category folder and select  "Create". 

 

 

 

 

 

 

 

 

 

A DialogBox appears that asks you to select one of two relationships that will tie the "OOCASE" category to the 
new object you are about to create. 

Select "linkToModelElement" and press OK. 

A ModelElement is the name for an object that describes a software representation in the computer of an object 
that carries information about something real or physical in the world or some immaterial object in the computer 
that we need to store information about to track or model what is going on in the real world, so we can provide 
decision support for what to do next. Perhaps after a analysing the computer stored information from all possible 
angles and views. The term ModelElement was standardized by the Object Management Group, an industrial 
democratic membership organization that united the emerging needs of standardizing computer communication 
protocols and terminology for object-oriented electronic network communication between computers in software 
industry in the late 1980's [OMG]. This organization has plenty of knowledgeable members who create standards 
that are a backbone of mainstream software industry today with a legacy and development requirements and needs 
that goes faar beyond  anything that is addressed here. 
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Now a new DialogBox appears where you can select the Class of ModelElement you want to link to the 
"OOCASE" category, so that the software will display this object below this Category folder. 

Select "DocumentRecord" and press OK. 
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Now you have created a DocumentRecord on which you according to 2.2.4 below can "copy-paste" a reference to 
this DocumentRecord for example: 

[ROJTEC 2018d] ROJTEC, "OOCASE User Manual", ROJTEC, 2018, 
file://$(DocumentDictionary)/DATA/Foundational_Engineering_Database_Theory_Products/4_Products/[ROJTE
C 2018d]/OOCASE_User_Manual_181211.pdf 

The DocumentRecord will absorb the information in the reference and allow you to keep track of it and perhaps 
extend it further with a TableOfContents if the reference contains more pages than you can read at one 
uninterrupted slice of time. A scheduling that will give you a time-estimate for reading to enable your calendar-
time scheduling. Something that may speed up your recall of what you have read before, after a delay of days or 
more on  more urgent events that had to be handled. 

2.2.4 Pasting a Reference on a DocumentRecord 

In this tutorial you double-click on the file you find in the installation directory of DocumentDictionary, named 
DATA\Foundational_Engineering_Database_Theory_Products\4_Products\ReferenceList.txt. In Notepad it looks 
like this: 

 



  

12 

 

Copy the text of the reference you want to store in the DocumentRecord. 

Then you select the DocumentRecord named  '<no Authors> "<no Title>" in the DocumentDictionary window, 
right-click and select "Paste External Clipboard". 

 

Double-click the DocumentRecord and inspect it's contents in a Form. 

In the form select Object->Edit Details, and a full form will appear that displays what the Clipboard text 
interpretation process has extracted. 
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2.2.5 Pasting a TableOfContents on a DocumentRecord  

 
Now we need to copy-paste the "TableOfContents" of the [ROJTEC 2018d]  document. 
 
In the DocumentDictionary installation directory below 
DATA\Foundational_Engineering_Database_Theory_Products\4_Products\  
you find the file [ROJTEC 2018d].txt that contains a table of contents. This is a simple copy/paste 
from the PDF in the subdirectory [ROJTEC 2018d]\ OOCASE_User_Manual_181211.pdf.  
When you open this file in Notepad it looks like this: 
 

 
 
Most table of contents files like the one above can be created with a plain copy/paste of the 
TableOfContents from the PDF file, with some minor editing with the Edit -> Replace command in 
Notepad, and adding of a hierarchical numbering infront of the chapter and sections to make the 
hierarchical structuring understandable for a computer program. 
 
Select all the text with Ctrl+a, then press Ctrl+c to copy it into the clipboard. 
Then select the "[ROJTEC 2018d]" DocumentRecord in the DocumentDictionary window, right-
click and select "Paste External Clipboard". 
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When the Paste External Clipboard command is executed on a DocumentRecord, the text in the 
clipboard is checked if it begins with the word "TableOfContents" on a single line. If so, the rest of 
the text in the external clipboard is extracted by the DocumentDictionary program. ContentRecords 
are created below the DocumentRecord and organized in a hierarchical structure that reflects the 
table of contents. 

2.2.6 Updating the PageCount information in a "TableOfContents" 

Before we can calculate an estimate of the time it will take to read the document, the page 
information in the ContentRecords needs to be processed. 
Issue the command "Tools -> Update or Create DocumentRecord PageCount". 
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The command will process the ContentRecords, derive an EndPage for each ContentRecord, and 
with the StartPage which came from the original TableOfContents, calculate the PageCount. 
Once finished the command will open a Report with messages about the calculated page 
information for each DocumentRecord. 
 

 
 
Note: If you have NOT selected any DocumentRecord when issuing the "Tools -> Update or Create 
DocumentRecord &PageCount", all DocumentRecords in the DocumentDictionary model will be 
processed. 

2.2.7 Creating a Reading Agenda Report 

With the PageCount information processed, it is now possible to calculate the time it will take to 
read a document. The time it takes a user to read a page can be configured for different login 
identifiers. If you login as Student, the reading speed is already configured to 3 minutes per page in 
the example DocumentDictionary profile instance tree. 
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Select the "[ROJTEC 2018d]" DocumentRecord in the Issue the command "Report->Web Report 
Selection".  
The selected object will then generate a web-page that can be found in the <DocumentDictionary 
install directory>\webport, by sorting this directory according to time, so the latest generated page 
appears first in the explorer window. 
A web report for a DocumentRecord can also be opened directly in a web browser by selecting the 
ElectronicEdition object that stores a particular Universal Resource Locator (url) to a web page, or 
to the particular web report generated in the webport directory. Open the report with: 
 

 
 
The generated DocumentRecord web report when viewed in internet explorer can be seen on the 
following pages. If you scroll down towards the end of the TableOfContents, you find an estimate 
of the total time it will take to read the document. 
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2.3 Calibrating Your Reading Speed 
Reading Speed is measured in minutes per page in DocumentDictionary. Most undergraduate 
students can perform at 3 minutes a page on ordinary Prose on pages with 40-50 lines of text. 
Reading Speed depends very much on the experience of the person reading, and the quality and 
information density within the text. Pages packed with tables and numbers may require more time 
to read, if the reader evaluates each number into information that is useful for the readers 
understanding of a subject. 
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Estimated TimeToRead and the actual time spent on reading a document, chapter or section can be 
displayed directly in the DocumentCategoryTree in DocumentDictionary. To turn the information 
on, issue the command View->Read Status. 
 

 
 
 
Now DocumentRecords and ContentRecords are suffixed with an estimated TimeToRead. 
Note: You can turn of the display of TimeToRead with View->Name. 

2.4 Recording ReadTime for a Document or ContentContainer 
ReadTime is the actual measured time to read a Document or ContentContainer within a Document. A 
ContentContainer is the object that stores information about a Chapter or section in the TableOfContents of a 
DocumentRecord. 

To get an fact-based estimate of how much time it actually takes to read a document, for the purpose of being able 
to schedule enough time to read other documents of a similar “ReadingSpeedCategory” in the future, 
DocumentDictionary provides a “Read” menu with the functionality of a StopWatch. 
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All personal “Read” information is stored in a separate “ReadLog” Profile within the model and saved in the .ddi 
file. If a personal DocumentDictionary after personal use is needed for sharing, all personal information in the 
“ReadLog” profile can be deleted. The file is saved under another name and the accumulated DocumentRecords 
and ContentRecords with the study plan remain.. 

A Teacher may for example establish a fact-based baseline for a new course book, by reading the book her/him 
self and thus get an estimate of how much time the students will at minimum have to spend to read the book. After 
some fact-based personal experiences of this kind, realistic “rules-of-thumb” can be established. 

 

A Student may develop several ReadingSpeedCategories for various types of books, documents and teaching 
material to be able to schedule enough time for plain reading before the exam.  

A day of leisure is recommended after a multiday batch of bulk-reading and personal organization of the material 
has been done. That will provide subconscious processes access to past experiences that may contain valuable 
additions that may improve the higher understanding of the course content. Sometimes personal insights appear at 
this stage that can serve as "remembering keys" some years later when the course content is needed for practical 
work.. It is valueable to create some ContentRecords for your personal appendix of a course book or lecture 
material. There you can record your own personal insights, for example how you recall and understand machinery 
or processes you have been working with in the past, in the light of newly studied theory, and thus combine your 
personal knowledge into a coherent whole that is available to you "quick as a thought".  

 

The Read functionality is strait forward. When starting to read a document or content container, select the object 
that represents the material to read, and issue Read->Begin. 

If you get a “phone call” issue Read->Pause. 

When the call is complete and you are ready to resume, issue Read->Resume after Pause.  

When the ContentRecord to read is finished, issue Read->End. 

The recorded ReadTime will be displayed in green after the ContentRecord or DocumentRecord that represents 
the read material. 
 

 
 

There is functionality for adding personal comments to ContentRecords, such as questions and keywords for 
discussion of the contents of the text for recall at a later time. 

 

Try it now in practice by reading some chapters while you still have this turorial fresh in mind. The OOCASE 
User Manual is a perfect choise. 

 

Save your DocumentDictionary model with File->Save after you have made changes. 
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2.5 Update or Create AuthorRecords and AuthorDocuments 
When planning studies or doing research it is frequently helpful to have an index over publications 
by a particular author who writes about topics you are interested in.  
 
Issue the command "Tools -> Update or Create AuthorRecords and AuthorDocuments". 
This will update or create a derived index of AuthorRecords from the data in the DocumentRecord 
attribute authors. This index is visible in the AuthorCategoryTree in the DocumentDictionary 
Window.You can there select and expand an AuthorRecord folder and see all DocumentRecords in 
the DocumentDictionary that has this author's name in its autors attribute. 
 
An AuthorDocument object is a Link-object that relates a DocumentRecord with an AuthorRecord. 
It has the same function as the CategoryLink, that links a Category to another ModelElement.   
 

2.6 Find a string in a DocumentDictionary 
When a DocumentDictionary gets large, or has not been used for some time, the search 
functionality in DocumentDictionary is helpful. 
 
Issue "Edit->Find in Model". 
 
A search object editor on the DocumentDictionary Model object appears: 
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Enter the string you want to search for in the field labeled "String to search for:", for example 
"Information Quantity" and press the Search button. 
 
An AutoObjectReport appears with a ReportEntry for each found object in the DocumentDictionary 
model that contains this string.  
 

 
 
You can double-click on any of the ReportEntries to open an object editor on the reported object 
and inspect it. 
You can also right-click on any ReportEntry and select "Navigate" in the background menu. This 
will locate and select the reported object in the DocumentCategoryTree in the DocumentDictionary 
Window. 
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References 
 
<ToDo:A list of GREAT books on studying techniques that I read in the 1980:es. 
 
I don't think there has been any development at all in the field of studying techniques for 
undergraduate students or professional life-time students, for basic foundational bulk theory. 
 
However the interactive course material made available i software tools has improved a lot. 
Real-time interaction with simulation models and fast iteration loops where you change your 
equations or parts in your algorithmic program and get a visualization back immediately, speeds up 
the learning process. 
 
However without having understood the foundational underlying theory for such elegant 
applications, they may become a distraction from the tougher intellectual effort to really grasp the 
underlying theory. 
 
The basic biological functionality of human beings has not changed at all in 40 years. People in the 
1970-1980'es did not have that rich access to multi window software tool, and where thus forced to 
do a higher amount of intellectual processing with the biological equipment they had in their own 
brains. Leading to developments and capabilities that do not evolve without training and practice. 
 
It is never to late to start to take up an advanced subject again. Gathered life experience from 
decades in other knowledge domains may actually make re-entry into advanced theory a wonderful 
experience full of awe. 
That is what being a Student is about! 
> 
 
 


